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Before Reading This Manual 

The contents of this manual are current as of February 2025. 

Some of the software, hardware, and operating procedures described in this manual are common even if they are 
not the specified versions or devices, but some of them may not be common. 

Symbols in Documentation 

 Info Provides supplementary information. 

 Point Important points are included. 

 Reference Reference materials and sites are introduced to deepen your understanding. 


  Note Although not discussed in detail in this document, the information and knowledge required is provided. 

 Prohibited Notes and what not to do are provided. 

 

Notations in sentences 

Underline Click to jump to another chapter in the document or to an external site. 

Bold italic Indicates the characters displayed on menus and windows when operating on the screen. 

xxxxxxx↵ Indicates the command string to be entered. 

Shaded Indicates the tool to be used. 
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 Overview 

In this exercise, you will learn how to develop Cyclone® V SoC hardware and software using the Cyclone® V SoC FPGA 
evaluation kit DE0-Nano-SoC Kit/Atlas-SoC Kit (Atlas-SoC board below) or DE10-Nano Kit (DE10 Nano board below). 

By completing this exercise, you will learn the basic operations of the Quartus® Prime development software, the 
development environment for Altera® SoC FPGA, the Platform Designer system configuration tool (formerly known as 
Qsys System Integration Tool), and the SoC FPGA Embedded Development Suite (SoC EDS) software development 
environment. 

This exercise consists of the following 4 parts: 

 Lab 1: Hardware Exercise 

 Lab 2: Software Exercise (1) 

 Lab 3: Software Exercise (2) 

 Lab 4: Linux Application Exercise (optional exercise) 

Lab 1 uses Quartus® Prime to configure the hardware including the Arm® processor and design a simple SoC system. 

Lab 2 uses the SoC EDS tool to generate the 28 nm generation boot loader, Preloader. 

Lab 3 uses Arm® Development Studio for Intel® SoC FPGA Edition (Arm® DS below) to develop software and debug 
bare metal applications. 

Lab 4 uses an SD card image to run Linux on the SoC device and then runs and debugs the application using Arm® DS.  

 Info: 

Lab 4 is an optional exercise that will not be available at our company SoC Startup Trial Seminar due to time 
constraints. 

 

 Info: 

Starting with version 20.1, the SoC EDS standard integrated development environment tool is Arm® Development 
Studio (Arm® DS). The previous product, Arm® Development Studio 5 (DS-5™), is available for pre-version 19.4 
environments. 
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 Requirements 

The following software is used in this exercise. 

 Quartus® Prime Standard Edition v20.1 (Lite Edition is also available) 

You will also need to register Cyclone® V as Device Data. 
Download and installation instructions are available at: 

How to Download Intel® Quartus® Prime Development Software and Questa* - Intel® FPGA Edition 
How to Install Intel® Quartus® Prime Development Software and Questa* - Intel® FPGA Edition 

 SoC FPGA Embedded Development Suite Standard Edition v20.1 (SoC EDS) 

For installation instructions, refer to the following website: 
How to install SoC FPGA Embedded Development Suite (SoC EDS) ver. 20.1 

 Exercise Data (SoC-Trial_Seminer_Lab_data_atlas_de10nano_v20.1_r2.exe) 

When you double-click the exercise data .exe file, it will be expanded to the following location by default: 

C:¥lab¥soc_lab¥cv_soc_lab 

This document assumes that the exercise data is expanded to the above location. 

 Host PC OS: Windows® 10 Enterprise 

This exercise uses Windows® 10 Enterprise (version 1803) to verify operation. 
 


  Notes: 
When using SoC EDS v20.1std in a Windows® 10 environment, the tools bsp-create-settings and sopc-create-header-
files must be resolved before running.  
After setting up SoC EDS, you should also review the following reference sites: 


  Reference: 
Macnica Altera FPGA Insights "Workaround for bsp-create-settings execution error in SoC EDS environment" 


  Reference: 
Macnica Altera FPGA Insights "Workaround for sopc-create-header-files execution error in SoC EDS environment" 

* This exercise uses these two tools, so both of these should be addressed. 

 

 
  

https://malt.zendesk.com/hc/en-us/articles/35918370872985
https://malt.zendesk.com/hc/en-us/articles/35993815156377
https://malt.zendesk.com/hc/en-us/articles/35551014813977
https://malt.zendesk.com/hc/en-us/articles/900005302026
https://malt.zendesk.com/hc/en-us/articles/900005301606
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 Board Setup 

This section describes the board setup required to complete exercises 1, 2, and 3. 

 Board Layout 

The following diagram illustrates the layout of the Atlas-SoC board used in this exercise. 
The DE10 Nano board is basically the same. 

 

 

 

 

 

 

 

 

 

 

Figure 2-1. Atlas-SoC board layout diagram 

 Power and cable connections 

Connect the AC adaptor and cables as follows. 

 Connect the power (AC adaptor) to the DC input (J14). 

 Use the Mini USB cable to connect the work PC to the onboard USB-Blaster™ II connector (J13). 

 SW10 settings 

Make sure that the SW10 (MSEL setting switch) is set as follows. 
This setting puts the FPGA in FPPx32 mode. 

Table 2-1. SW10 Settings 

Board Reference Signal Name Settings 

SW10. 1 MSEL0 ON (“0”) 

SW10. 2 MSEL1 OFF (“1”) 

SW10. 3 MSEL2 ON (“0”) 

SW10. 4 MSEL3 OFF (“1”) 

SW10. 5 MSEL4 ON (“0”) 

SW10. 6 N/A N/A 

 

Figure 2-2. Jumper settings 
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 Lab 1: Hardware Exercise 

In this section, you will use Quartus® Prime and Platform Designer to design the hardware including the following 
Arm® processors. 

Altera® SoC FPGA is not limited to Cyclone® V, but uses a tool called Platform Designer included in Quartus® Prime to 
configure the system. Platform Designer provides a set of components that can be implemented on the FPGA side, 
including Hard Processor System (HPS) blocks, and allows you to optimize resources by implementing only the desired 
components. In addition, since the created system can be easily ported to other devices if the peripherals are supported, 
you can use the system itself as a design asset. 

In this exercise, several components and clock source components are already implemented in the Platform Designer 
system to shorten the exercise time. To do this, you will add an HPS block (the blue block in the bold box) and connect 
the existing components. You will perform the following exercises: 

Exercise: 

 Add an HPS component to an existing Platform Designer system 

 Configure the HPS interface and other parameters 

 Connect existing components to HPS 

 Generate the Platform Designer system 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-1. Block diagram of the SoC system designed in Lab 1 
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 Step 1: Hardware Exercise Open the design project 

As you proceed with the exercises, carefully read all the instructions in each step of this manual. 

In this manual, the working directory is described as C:¥lab¥soc_lab folder. If you have changed the working 
folder, read it again according to your environment. 

Let's get started. 

____ 1. Start Quartus® Prime from the installed Quartus® Prime 20.1 Standard Edition (or Lite Edition) development software. 
If you leave the default, you can find it below. 

Windows Start => Intel FPGA 20.1.1.720 Standard Edition/Lite Edition => Quartus (Quartus Prime 20.1) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-2. Start Quartus® Prime 
  

or 

Start from the Windows Start Menu 

Start from the Desktop Icon 
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____ 2. From the Quartus® Prime menu bar, select File => Open Project and select soc_system.qpf located in  
C:¥lab¥soc_lab¥cv_soc_lab.  
This qpf file is the project file in Quartus® Prime. 

 

 

 

 

 

 

 

 

 

Figure 3-3. Opening the Quartus® Prime Project 

____ 3. Select the board. Refer to the figure to set the board to be used. 

 For DE0 Nano-SoC/Atlas-SoC boards: select atlas 
 For DE10 Nano boards: select DE10 Nano 

By making this setting, you will be able to use the pre-set information such as pin placement and device to be used for 
the board to be used this time. 

 

 

 

 

 

 

Figure 3-4. Selecting the board to be used 
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____ 4. Launch Platform Designer from Tools in Quartus® Prime. Alternatively, click the Platform Designer icon in the toolbar 
to launch Platform Designer.    Click to launch Platform Designer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-5. Starting the Platform Designer 

____ 5. Open the soc_system.qsys file. 

 

 

 

 

 

 

 

 

 

 

Figure 3-6. Opening the Platform Designer File 
  



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ve r. 2 0 . 1 / Re v. 4  A p r i l  2 0 2 5                   1 2 / 1 1 1                     A LT I M A  C o m p a ny,  M a c n i ca ,  I n c .                    

 

 

Let's first briefly explain how to use Platform Designer. 

There are 3 main screens in Platform Designer: IP Catalog, System Contents, and Message Window. 

The IP Catalog contains components that can be used by Platform Designer. You add the components you want to 
implement to System Contents. You then connect the components in System Contents to create a system. 

The hard macroized part of the chip called HPS is also available as a software component in IP Catalog. By 
implementing this component in the Platform Designer system, you can use it on the HPS side of SoC devices. 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-7. Platform Designer Screen 

The following components (white) have been installed in the opened Platform Designer system. Add and configure 
the HPS block (blue) for this system, and connect the installed components. 

■ Implemented component (white): 

 Clock source 

 On-chip memory 

 PIO peripheral for LED/Button control 

 DIP switch PIO 

 Button PIO 

 LED PIO 

■ Components to be added in the exercise (blue): 

 HPS 

Platform Designer provides a setting screen for each IP. Double-click a component in System Contents to open the 
setting screen for that component. 

  

IP Catalog 

System Contents 

Message Window 

Figure 3-8. Platform Designer system to be designed 
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____ 6. Double-click the Clock Source component (clk_0) and make sure that the Clock Frequency is set to 50 MHz to match 
the oscillator on the development board. 

____ 7. Make sure that Clock frequency is known is checked. 

 

 

 

 

 

 

Figure 3-9. Checking the Clock Source 

____ 8. Click Close (X) on the Parameters tab to close the Parameters tab. 

The settings of each Platform Designer component are retained when you close the Parameters tab, unless you close 
Platform Designer. 
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 Step 2: Adding HPS Components 

The HPS consists of Dual-core Arm® Cortex™-A9 MP Core processors and various peripherals. As shown below, the 
Altera® SoC FPGA consists of two main blocks: the HPS block and the FPGA block. 

In this step, you add and configure the HPS block in the Platform Designer system. You can configure the HPS block 
in the HPS block in the Platform Designer system. 

The GUI used to configure the HPS provides multiple tabs (FPGA interfaces, Peripheral Pins, HPS Clocks, SDRAM), and 
you can configure settings for each of them. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-10. HPS Block Added to the Platform Designer System 

From the next page, add an HPS block to the Platform Designer system and make various settings. 
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____ 1. In the search box under the IP Catalog tab, enter processor. 

 

 

 

 

 

 

 

 

 

 

Figure 3-11. IP Catalog Search Box 

____ 2. Double-click Arria V/Cyclone V Hard Processor System. 

This component is the block for configuring HPS components. The dialog box for the HPS component to be configured 
appears. This window opens as a separate window only the first time. After clicking the Finish button, if you want to 
redisplay it the second time or later, double-click the HPS component from the System Contents tab. 

The FPGA Interfaces tab allows you to specify whether to use signals between the HPS and the FPGA connected inside 
the device. Depending on the settings, the status of the HPS side can be notified to the FPGA, or the FPGA side can 
control the HPS side. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-12. Internal bus between the HPS peripheral and the FPGA 
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____ 3. Click the FPGA Interfaces tab to disable Enable MPU standby and event signals, which are enabled by default. 

 

 

 

 

 

 

 

Figure 3-13. FPGA Interface tab settings 

 Info: 

This is an internal signal that indicates whether the microprocessor is in standby mode or the CPU can wake up. 
You can connect this input signal to logic high for permanent effect, or as a processor event. 

____ 4. Make sure Enable HLGPI Interface is unchecked and disabled (default). 

 Info: 

This is an option to use an unused pin (14bit) on the SDRAM interface as a general-purpose input only pin. This 
signal is not required for this exercise. 
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Next, configure the bridge between the HPS and the FPGA. 

There are ports between the HPS and the FPGA that are master and slave respectively. There are two ports from the 
HPS to the FPGA and one port from the FPGA to the HPS. The two ports from the HPS to the FPGA are HPS-to-FPGA 
interface and lightweight HPS-to-FPGA interface respectively. The one port from the FPGA to the HPS is FPGA-to-HPS. 
For all ports, you can set the bus width and use or not use the port according to the path to be accessed. 

When accessing from the Arm® processor or the Master on the HPS side, 
you can access by specifying the address of "Bridge address + FPGA component offset address." The bridge address is 
as shown in the following figure. 

HPS-to-FPGA interface is 0xC000_0000 

Lightweight HPS-to-FPGA interface is 0xFF20_0000 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 3-14. HPS and FPGA internal bus and address map viewed from Arm 


  Reference: 

For more information on the HPS to FPGA interface, please refer to the Macnica website technical information. 
See also. 

Beginner's Guide to SoC - How to access between HPS-FPGA (Cyclone® V SoC/Arria® V SoC) 

Make the settings on the following page.  

https://malt.zendesk.com/hc/en-us/articles/36662109888537
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____ 5. In the AXI Bridges section, set the FPGA-to-HPS interface width to Unused, the HPS-to-FPGA interface width to 64 bit, 
and the Lightweight HPS-to-FPGA interface width to 32 bit. 

 

 

 

Figure 3-15. Configuring AXI Bridges 

 Info: 

Enabling FPGA-to-HPS interfaces allows the master in the FPGA to access the peripheral of the HPS. This exercise 
does not use it. 

When HPS-to-FPGA interface is enabled, HPS becomes the master and can access the peripheral of the FPGA. HPS-
to-FPGA interfaces can be 32/64/128 bit wide, but for this exercise we will use the middle 64bit width. 

____ 6. Scroll down the FPGA interface page to find more options, including FPGA-to-HPS SDRAM interface, Resets and DMA 
Peripheral Request sections. 

____ 7. Scroll through the FPGA interface window until you see FPGA to HPS SDRAM Interface. 

____ 8. Click on the F2h_sdram0 interface and delete the interface by clicking the    button. 

This is a broadband port that allows direct access from the FPGA to the SDRAM on the HPS side. It does not involve an 
interconnect and ACP (Accelerator Coherency Port) for fast access. On the other hand, data coherency is up to the user. 

This is not going to be used, so I will delete the port. 

 

 

 

 

 

Figure 3-16. FPGA-to-HPS SDRAM Interface Configuration 
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____ 9. Scroll down to the Resets section. 

____ 10. In the Resets section, make sure all options for HPS reset are disabled. 

____ 11. In the DMA Peripheral Request section, make sure all lines under the Enabled column display No. 

 Info: 

Enabling DMA peripheral request allows the HPS DMA controller's Peripheral Request signal to be connected to 
the FPGA fabric. 
Normally, this should be set to No, unless you are using the Peripheral Request signal for DMA transfer. 

____ 12. In the Interrupts section, make sure the Enable FPGA-to-HPS interrupts option is disabled. 
In this case, the component implemented in the FPGA will not interrupt the Arm® processor. 

The Resets/DMA/Interrupts settings are as follows (no changes from the default): 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-17. Resets/DMA/Interrupts Settings 
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 Step 3: HPS Peripheral Settings (MAC, UART, I2C, SDIO, USB) 

The Peripheral Pins tab enables HPS peripherals that are hardcoded inside HPS. 

Many HPS pins are shared by up to 4 peripherals. However, only 1 peripheral can be used. Therefore, pin assignments 
must be specified so that the peripherals to be enabled do not conflict. Pin assignments can be selected from up to 3 
different parameters (HPS I/O Set 0 ~ 3). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-18. HPS I/O Pin Multiplexer 
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____ 1. Select the Peripheral Pins tab. 

____ 2. Set the EMAC1 pin of the Ethernet Media Access Controller to HPS I/O Set 0. 

____ 3. Set the EMAC1 mode of the Ethernet Media Access Controller to RGMII. 

____ 4. Set the SDIO pin of the SD/MMC Controller to HPS I/O Set 0. 

____ 5. Set the SDIO mode of the SD/MMC Controller to 4-bit Data. 

____ 6. Set the USB1 pin of the USB Controllers to HPS I/O Set 0. 

____ 7. Set the USB1 PHY interface mode of the USB Controllers to SDR with PHY clock output mode. 

____ 8. Set the SPIM1 pin of the SPI Controllers to HPS I/O Set 0. 

____ 9. Set SPIM1 mode of SPI controllers to Single Slave Select. 

____ 10. Set UART0 pin of UART controllers to HPS I/O Set 0. 

____ 11. Set UART0 mode of UART controllers to No Flow Control. 

____ 12. Set I2C pin of I2C controllers to HPS I/O Set 0. 

____ 13. Set I2C0 mode of I2C controllers to I2C. 

____ 14. Set I2C1 pin of I2C controllers to HPS I/O Set 0. 

____ 15. Set I2C1 mode of I2C controllers to I2C. 

Refer to the next page for the parameters after setting. 
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Figure 3-19. Configuring HPS Peripherals 
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In the Peripherals Mux Table section, you can see the placement of the pins you set up. 

A pin can only have one role. Therefore, multiple HPS peripherals cannot use the same pin, and the same pin cannot 
have the role of HPS Peripheral and GPIO. Therefore, use this Peripherals Mux Table section to see what each pin is 
used for. 

The left column shows the pin name, and if the pin is used, it is bolded. Pins that are not used as peripheral pins can 
be used as HPS GPIO pins. In this case, you can activate them by pressing the respective GPIO button for each pin. 

If there is a conflict for a pin, an Error is displayed in the Message Window and the pin field is highlighted in red so 
that you can see in real time which pin is causing the conflict. 

Let's set the pins that are not used as GPIO pins. 

____ 16. Enable GPIO09 by clicking GPIO09 in the Peripherals Mux Table section. 

 Point: 
The response may take a while, so be careful not to press it too many times. 

 

 

 

 

 

 

 

 
Figure 3-20. HPS GPIO09 settings 

 Point: 

If you cannot click it, select [Finish] in the lower right corner of the HPS component dialog box, 
or click "x" in the Parameters tab to close the HPS component dialog box. 
Double-click the hps_0 component again to open the parameters window and continue working. 

 

 

 

 

 

 

Figure 3-21. What to do if you cannot click during GPIO settings 
  

 

or 
 

Double-click the hps_0 component. 
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____ 17. Similarly, enable GPIO35, GPIO40, GPIO53, GPIO54, and GPIO61. 

 

 

 

 

 

Figure 3-22. HPS GPIO settings 

____ 18. After configuring, make sure that there are no errors other than the two errors shown below (these two errors will be 
resolved later). 

 

 

 

 

 

 

 

Figure 3-23. Example of display when there is no pin conflict error 

For example, if the error shown in Figure 3-24. appears, there is a conflict between the pins of SPIS0 and UART0. Check 
whether there is an error in the setting and correct it. 
In this example, an error occurs because SPIS0, which should not be used, is to be used. If the setting is Unused, the 
error disappears. 

 

 

 

 

 

 

 

 

 

 

Figure 3-24. Example of display with a pin conflict error 

An error occurs that SPIS0 and UART0 conflict. 

An invalid SPIS0 is set ・・・ 



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ve r. 2 0 . 1 / Re v. 4  A p r i l  2 0 2 5                   2 5 / 1 1 1                     A LT I M A  C o m p a ny,  M a c n i ca ,  I n c .                    

 

 

 Step 4: Set the HPS Clock 

The HPS Clocks tab sets the Clock source and frequency. All of these parameters are managed by the Clock Manager 
Component. 

The parameters set in this tab are used when the boot loader (Preloader software) is generated. The Preloader is 
generated by "4. Lab 2 - Software Exercise (1) Generate Preloader." 

____ 1. Select the HPS Clocks tab. 

____ 2. Select the Input Clocks tab. 

____ 3. Ensure that the EOSC1/EOSC2 clock frequency is set to 25 MHz. Also ensure that all FPGA-to-HPS PLL Reference clocks 
are disabled. The EOSC1 is a dedicated pin on the HPS side and is the clock source required to generate the clock for 
the HPS MPU. The Atlas-SoC board and the DE10 Nano board used in this article are set to 25 MHz. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-25. HPS to FPGA Clock Settings 
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____ 4. Select the Output Clocks tab. 

____ 5. Make sure that the settings are as shown below (no change from the default). This tab allows you to set the operating 
frequency of each HPS peripheral. The PLL setting is automatically calculated according to the set value. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-26. Configuring HPS to FPGA Clock 
  

800.0 MHz for the DE10 Nano 

200.0 MHz for the DE10 Nano 

100.0 MHz for the DE10 Nano 
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 Step 5: Configuring SDRAM 

The SDRAM tab provides options for configuring parameters for the SDRAM controller on the HPS side and the 
connected DDR. Within the SDRAM tab, there are four additional tabs (PHY Settings, Memory Parameters, Memory 
Timing, Board Settings) for SDRAM configuration. 

____ 1. Click at the bottom of the Arria V/Cyclone V Hard Processor System window. 

This action adds the HPS component to the Platform Designer system (required to display the Presets window in the 
next step). 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-27. Preparing to display the Parameters window 

____ 2. Double-click the HPS component in the System Contents window to display the HPS option settings in the Parameters 
window again. 
This is necessary to display the Preset window in the next step. 

 

 

 

 

 

 

 

 

 

Figure 3-28. Redisplay the HPS parameter setting window 
  

Added to the System Contents window 
Double-clicking the hps component ・・・ 

The HPS Parameters Settings window is displayed again 
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____ 3. Click the SDRAM tab in the Parameters window. 

This time, we will use the preset SDRAM on the Atlas-SoC board. 
Make sure that the Presets window is displayed. 

 Info: 

If the Presets window is not displayed, select Platform Designer View menu => Presets to display it. 

If it is not displayed, select Platform Designer View menu => Reset to System Layout and select Preset again. 

____ 4. Select the Atlas_HPS_SDRAM preset in the Presets window. 

 

 

 

 

 

Figure 3-29. Select Preset 

____ 5. When you click , Atlas_HPS_SDRAM should be highlighted in bold. If it is, the settings are applied correctly. 

____ 6. If the SDRAM tab is not visible, click the SDRAM tab. 

____ 7. Click the PHY Settings tab and verify that the settings are as shown below. 

 

 

 

 

 

 

 

 

 

Figure 3-30. Verify PHY Settings 
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____ 8. Click the Memory Parameters tab and verify that the settings are as shown below. 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-31. Memory Parameters 

____ 9. Scroll down to the Memory Initialization Options section and verify that the ODT Rtt nominal value is set to RZQ/6. 

 

 

 

 

 

 

 

 

 

Figure 3-32. Memory Initialization Options 
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____ 10. Click on the Memory Timing tab and verify that the settings are as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-33. Memory Timing 
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____ 11. Click on the Board Settings tab and verify that Use Altera‘s default settings is selected in the Setup and Hold Derating 
and Channel Signal Integrity sections. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-34. Board Settings (1) 
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____ 12. Scroll down to the Board Skew section and verify that the board skew is as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-35. Board Settings (2) 

____ 13. Select File menu => Save in Platform Designer to save the HPS parameter settings specified in the previous steps. 
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 Step 6: Setting the HPS Clock and Export Signal 

In this step, you will set the HPS H2F bridge clock and the LWH2F bridge clock. 

The clocks set here are the clocks on the FPGA side of each bridge (h2f_axi_clk and h2f_lw_axi_clk shown below). The 
clocks on the HPS side are l3_main_clk and l4_mp_clk, which are set in "3-4. Step 4: Set the HPS Clock," and are 
different from the clocks set here. The difference in clocks is absorbed within the bridge. 

The HPS export signal is also set. This export signal is used for communication outside Platform Designer. For example, 
it is used to connect Platform Designer to other logic on the FPGA and to place it on pins. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-36. Clock between HPS and FPGA 
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____ 1. Go to the System Contents tab. 

____ 2. By specifying the signal name in the Export column, you can route the signal to the outside of the Platform Designer 
system. Make sure that the hps_io port of the HPS component you just added is exported with the signal name hps_io. 

____ 3. Similarly, make sure that the memory port of the HPS component is exported with the signal name memory. This is the 
IO of the SDRAM on the HPS side that you just configured. 

____ 4. Export the h2f_ rest of the HPS component. Double-click the Export column of H2f_reset. 
Rename it to "h2f _ reset" and press Enter to export. 

____ 5. Configure the Clock Input interface h2f_axi_clock on the HPS. Select clk_0 from the pull-down menu in the Clock 
column next to H2f_axi_clock and connect clk_0 to h2f_axi_clock. 

____ 6. Configure the Clock Input interface h2f_lw_axi_clock on the HPS in the same way. Select clk_0 from the pull-down 
menu in the Clock column next to H2f_lw_axi_clock and connect clk_0 to h2f_lw_axi_clock. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-37. Setting the clock and export signal 

Now that clk0 is connected, the two error messages in the Message Window in Figure 3-23. should disappear. 
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 Step 7: Connecting HPS Components to Other Components 

In this step, you will connect the HPS components added to the Platform Designer system and the components 
already implemented in the Platform Designer system. Since the FPGA will operate at clk_0 (50 MHz), clk_0 is already 
connected to each component. 

____ 1. Verify that the Clock Input interface of the Onchip_memory2_0 component is connected to clk_0. 

____ 2. Verify that the Clock Input interface of the Led_pio component is connected to clk_0. 

____ 3. Verify that the Clock Input interface of the Dipsw_pio component is connected to clk_0. 

____ 4. Verify that the Clock Input interface of the Button_pio component is connected to clk_0. 

____ 5. Select s1 of onchip _memory2_0, then right-click and select hps_0.h2f_axi_master from the connection submenu. This 
connects the s1 interface of the onchip_memory2_0 component to the HPS h2f_axi_master. This configuration allows 
the Arm® processor to access onchip_memory on the FPGA side. 

 

 

 

 

 

 

 

 

Figure 3-38. Connecting components 

____ 6. Similarly, right-click s1 of button_pio and select hps_0.h2f_lw_axi_master from the connection submenu. This 
connects the s1 interface of the button_pio component to the HPS h2f_lw_axi_master. 

Notice that the connection destination is h2f_lw_axi_master. The same applies to each subsequent PIO component. 

____ 7. Similarly, right-click s1 of dipsw_pio and select hps_0.h2f_lw_axi_master from the Connect submenu. This connects 
the s1 interface of the dipsw_pio component to the HPS h2f_lw_axi_master. 

____ 8. Similarly, right-click s1 of led_pio and select hps_0.h2f_lw_axi_master from the Connect submenu. This connects the 
s1 interface of the led_pio component to the HPS h2f_lw_axi_master. 

  

Select s1 of onchip_memory2_0 and right-click 
Specify a connection destination from the displayed 
connection submenu 
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____ 9. Select the HPS component and use the up and down        buttons in the Platform Designer toolbar on the left side 
of the System Contents window to move the HPS component below clk_0. Use to move the HPS component below 
clk_0. 

The Platform Designer system after configuration is complete is shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-39. The Platform Designer system after configuration is complete 

Consider accessing led_pio. 

If you look at the second Base column from the right of led _pio, it is set to 0x0001_0040. This is the offset address of 
led_pio in Platform Designer. Earlier ____ 8 The master to access led_pio is HPS h2f_lw_ axis _master. Since the base 
address of the Lightweight HPS-to-FPGA bridge was 0xFF20_0000, accessing this led_pio would be: 

Bridge base address (0xFF20_0000) + Platform Designer offset address (0x0001_0040) = 0xFF21_0040 

Other components can be considered in the same way, and dipsw_pio would be 0xFF21_0080. 

Next, consider accessing onchip_memory. 

The base address of the HPS h2f_axi_master bridge, which is another path from the HPS to the FPGA, is 0xC000_0000. 
In this case, the Platform Designer offset address of onchip_memory connected to the HPS h2f_axi_master is 0x0, so 
in this case, the base address of the bridge (0xC000_0000) is the base address to access onchip_memory. 
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 Step 8: Connect Resets and Assign Base Addresses 

This step provides a bulk reset connection and automatic base address assignment. 

____ 1. Select Platform Designer System menu => Create Global Reset Network to connect all reset interfaces in the design in 
bulk. 

____ 2. Automatically assign base addresses for all components so that there are no duplicate addresses. Select System menu 
=> Assign Base Addresses. 

 

 

 

 

 

 

 

 

Figure 3-40. Reset Bulk Connect and Assign Base Addresses Automatically 

If you did Assign Base Addresses, nothing happened. 

In this exercise, the base addresses for each peripheral were fixed beforehand, so they were not automatically assigned. 

You can lock the address setting by using the lock symbol   next to the base address, as shown in Figure 3-41.. Each 
click toggles whether the address is locked or not. If you want to lock the address, lock it with the lock symbol after 
setting the address. You can also lock it by selecting Platform Designer's Edit menu => Lock Base Address. 

 

 

 

 

 

 

 

Figure 3-41. Fixing the Base Address 
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 Step 9: Checking the Platform Designer System 

____ 1. Verify that the Platform Designer system you designed is as shown in "Table 3-1. Connectivity of the Platform Designer 
system after design" below. Also refer to "Figure 3-39. The Platform Designer system after configuration is complete." 

To be consistent with the Quartus® Prime project for the exercise, make sure that the export signals are properly 
exported and named correctly. You can use any signal name in the actual design. There is no regulation on the order of 
components. 

Table 3-1. Connectivity of the Platform Designer system after design 

Component Port name Connection 

clk_0 

clk_in Export as clk 

clk_in_reset Export as reset 
clk Connect to all components 

clk_reset Connect to all components except hps_0 

led_pio external_connection Export as led_pio_external_connection 

dipsw_pio external_connection Export as dipsw_pio_external_connection 

button_pio external_connection Export as button_pio_external_connection 

hps_0 

h2f_axi_master Connect to onchip_memory2_0.s1 

h2f_lw_axi_master 

Connect to led_pio.s1 

Connect to dipsw_pio.s1 

Connect to button_pio.s1 

____ 2. Select Platform Designer View menu => Device Family and confirm that the Device Family is Cyclone V. 
The Device is 5CSEMA4U23C6 for the Atlas-SoC board and 5CSEBA6U23I7DK for the DE10 Nano board. 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 3-42. Device Family tab 
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____ 3. Select Platform Designer View menu Interconnect Requirements and set Limit interconnect pipeline stages to 1. 
Increasing the number of stages allows more timing, but also increases the logic of the FPGA. Make sure the Clock 
crossing adapter type is set to Handshake. Increasing the number of stages allows more timing, but also increases the 
logic of the FPGA. 
Make sure that the Clock crossing adapter type is set to Handshake. 

 

 

 

 

 

 

 

 

 

Figure 3-43. Set project parameters 
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 Step 10: Generate the Platform Designer system 

Generate the completed Platform Designer system. 

____ 1. Check the Message box on the System Contents tab for any remaining errors. If there are any errors, you must fix them 
before continuing. Ignore the blue warning at this time. 

 

 

 

 

 

Figure 3-44. Message window display 

____ 2. Select File menu => Save to save the Platform Designer system. [Close] when Save System Completed pops up. 

 

 

 

 

 

 

 

 

 

Figure 3-45. Saving the Platform Designer system 

____ 3. Select Generate menu => Generate HDL. 

 

 

 

 

 

Figure 3-46. Generating the Platform Designer system 
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____ 4. Check the settings in the Generation window and execute [Generate]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-47. Platform Designer System Generate Execution Window 

____ 5. Platform Designer's Generate menu => Show Instantiation Template shows an example of an instance that can be 
used when instantiating a top design. 
This time, it has already been instantiated, so there is no particular work to be done, but it is very useful when actually 
using it. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-48. Platform Designer system instance example 
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____ 6. After Platform Designer generation is complete, click the [Close] button to close the Platform Designer system 
generation dialog box and return to Quartus® Prime. 

 

 

 

 

 

 

 

 

Figure 3-49. Platform Designer system generation complete 

____ 7. Select Quartus® Prime's Project menu => Add/Remove Files in Project (The Settings dialog box appears with the Files 
category selected). 

 

 

 

 

Figure 3-50. Select Add/Remove Files in Project 

____ 8. Press the  button next to the File name field in the Settings dialog box and browse to the soc_system/synthesis 
folder from the Select File window. 

 

 

 

 

 

Figure 3-51. Settings dialog box 
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____ 9. Select the file Soc_system.qip and click [Open]. This qip file links the generated components in Platform Designer. 
Instead of registering each generated file individually, you can add a Platform Designer system to a project by registering 
this qip file. 

 

 

 

 

 

 

 

 

Figure 3-52. Specifying the Qip File 

____ 10. Verify that the file has been added. 

 

 

 

 

 

 

 

 

 

Figure 3-53. Register Qip file 

____ 11. Close the Settings dialog box with the [OK] button. 
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 Step 11: Set pin assignments and compile Quartus® Prime project 

For HPS-only IO, pin assignments are basically done automatically by the tool because pin placement is fixed. The 
exception is that SDRAM interfaces require a tool-generated script to be executed by the designer. To execute the script, 
first generate the netlist and then execute the script. 

Therefore, first run Analysis & Synthesis to create the netlist, then execute the script and compile the FPGA again. 

____ 1. In Quartus® Prime, select Processing menu => Start => Start Analysis & Synthesis. 

(Alternatively, click the Start Analysis & Synthesis button  on the GUI.) 

 

 

 

 

 

 

 

 

Figure 3-54. Start Analysis & Synthesis 

____ 2. When finished, verify that there are no errors. , there are no errors. The netlist is now created. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-55. Verify successful completion of Start Analysis & Synthesis 
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____ 3. Select Quartus® Prime Tools menu => TCL scripts. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-56. Starting the Tcl Scripts Window 

____ 4. Select hps_ sdram _p0_pin_assignments.tcl in soc_system => synthesis => submodules, and click the [Run] button  
(it takes a while for the application to take effect). 
This operation will apply the settings made in the SDRAM Controller tab of HPS, such as SDRAM IO Standard and OCT 
settings. 

 

 

 

 

 

 

 

 

 

 

 
Figure 3-57. Executing a Tcl Script 
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____ 5. When you have finished, click the [OK] button. 

 

 

 

 

 
Figure 3-58. Completing a Tcl Script 

____ 6. [Close] the Tcl Scripts window. 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-59. Close Tcl Scripts Window 
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____ 7. Select Quartus® Prime Processing menu => Start Compilation (Alternatively, click the Start Compilation button    on 
the GUI) to compile the FPGA. This compilation creates a .sof file that will be the working image of the HW and a handoff 
file that will be passed to the next software development. 

 

 

 

 

 

 

 

 

 

Figure 3-60. Run Start Compilation 

____ 8. Verify that the compilation is complete. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3-61. Compilation complete 
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 Step 12: Verify the output file 

Verify the output file in Quartus® Prime and Platform Designer. 

____ 1. Using Windows® OS Explorer, navigate to the output file folder (below). 

C:¥lab¥soc_lab¥cv_soc_lab¥output_files 

____ 2. Verify that there is a .sof file output in the above folder. 
atlas.sof for Atlas-SoC board 
DE10 Nano.sof for DE10 Nano board.  
As mentioned earlier, this file is the operational image file of the FPGA. 
This file will be written to the FPGA on the board using a tool called Programmer in a later exercise. 

____ 3. Using Windows® OS Explorer, navigate to the hardware/software handoff directory. 

C:¥lab¥soc_lab¥cv_soc_lab¥hps_isw_handoff¥soc_system_hps_0 

Under the above folder are the hardware/software handoff files generated by the tool. These files contain various 
data set in the HPS component screen of Platform Designer, information about the SDRAM interface of HPS, and 
other files. These files are used to generate a file called Preloader, which is used to initialize the HPS side. 
These files will be used to create Preloader in later exercises. 
 

Lab 1 Hardware Exercise Summary 

In this section, you configured the hardware including the Arm® processor by performing the following tasks: 

 Adding HPS components to the Platform Designer system 

 Configuring HPS components 

 Connecting HPS components to other components 

 Generating the Platform Designer system 

 Checking the files output by Quartus® Prime/Platform Designer 

Lab 1 is now complete. 
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 Lab 2 - Software Exercise (1) Generate Preloader 

In this section, you will generate Preloader using the handoff file created in "3. Lab 1: Hardware Exercise" 

 Point: 

In SoC EDS v20.1 (SoC EDS v19.1 and later), you need to build Preloader under the Linux OS environment. In this 
exercise, you will use the Windows Subsystem for Linux (WSL1) included with Windows® 10 to generate the boot 
loader. 

 

Preloader is a boot loader based on the U-boot second program loader (Later, u-boot spl) and customized for Altera 
® SoC FPGAs. Preloader is responsible for: 

 HPS pin multiplex configuration 

 HPS IOCSR configuration 

 HPS PLL and clock settings 

 HPS peripheral reset unreset 

 SDRAM initialization (calibration, etc.) 

 Deployment of the next stage boot image to SDRAM 

As mentioned above, Preloader provides the function of initializing the HPS block and loading the U-boot and OS 
into SDRAM. Preloader is automatically generated by using a handoff file that is automatically generated when Quartus® 
Prime/Platform Designer is designed. Therefore, the settings made in Quartus® Prime/Platform Designer can be applied 
to the HPS block without the user having to build initialization software. The sof file I just checked is the operating image 
of the FPGA side. On the other hand, the operating image of the HPS side is this file called Preloader. Note that the 
operating image is executed using different files for the FPGA side and the HPS side. 

Now let's create the Preloader. 
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 Step 1: Launch Embedded Command Shell 

____ 1. Launch the Embedded Command Shell included with the SoC EDS. 
Launch the Embedded Command Shell by double-clicking the startup script Embedded_Command_Shell.bat located 
in the Windows® Start menu or in the SoC EDS installation folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 4-1. Starting the Embedded Command Shell 
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 Step 2: Generate the bsp project 

Generate the bsp project required for Preloader generation from the Quartus® Prime design handoff information 
(hps_isw_handoff¥soc_system_hps_0). 

____ 1. Change the current directory of the Embedded Command Shell to the Quartus® Prime project directory. 

$ cd “C:¥lab¥soc_lab¥cv_soc_lab”  

____ 2. Then run the following command to create the directory where the bsp project will be output: 

$ mkdir -p software/spl_bsp  

____ 3. The following command generates the bsp project: The generated directory of the bsp project contains the source code 
that contains the definitions with the handoff information. 

$ bsp-create-settings ¥ 
   --type spl ¥ 

   --bsp-dir software/spl_bsp ¥ 

   --preloader-settings-dir “hps_isw_handoff/soc_system_hps_0” ¥ 

   --settings software/spl_bsp/settings.bsp  

Figure 4-2. Generating a Bsp project 

1. 1. 

2. 

3. 
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  Note: 

Error protection is required before using bsp-create-settings in SoC EDS v20.1std on Windows® 10. If an error occurs, 
take the corrective action described in the following reference sites and run bsp-create-settings again. 


  Reference: 
Macnica Altera FPGA Insights "Workaround for bsp-create-settings execution error in SoC EDS environment" 

 

 Info: 

The bsp project contains a Makefile but is not used in the SoC EDS v20.1 (SoC EDS v19.1 or later) environment. 
Running make under the bsp project will take you to the documentation page (URL) on the Rocketboards.org site 
with instructions for building the bootloader. 

See: Building Bootloader for Cyclone V and Arria 10 

 

bsp-create-settings created a bsp project under the software/spl_bsp directory. The source files contained in the bsp 
project will then be used to build Preloader. 

 
  

https://malt.zendesk.com/hc/en-us/articles/900005302026
https://www.rocketboards.org/foswiki/Documentation/BuildingBootloaderCycloneVAndArria10
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 Step 3: Launch Preloader Build Environment 

Generate the bsp project needed to generate Preloader from the Quartus® Prime design handoff information 
(hps_isw_handoff¥soc_system_hps_0). 

As noted at the beginning of Lab 2, building Preloader (boot loader) requires a Linux OS environment. This exercise 
uses Ubuntu 18.04 LTS running on WSL1. The following steps will be performed on the Ubuntu 18.04 LTS terminal of 
WSL, so please set up your WSL/Ubuntu 18.04 LTS environment beforehand. 


  Note: 

* In addition to WSL 1, which was originally released, there are two different WSL environments: WSL 2 
(Windows Subsystem for Linux 2), which is supported in Windows® 10 version 2004 and later. Please note that 
this exercise uses WSL 1. 

* This document uses Ubuntu 18.04 LTS, but you should read the version of Ubuntu as appropriate for your 
environment. 

 Info: 

To set up the WSL 1 environment, refer to the following article. 

 Reference:  
Macnica Altera FPGA Insights "Building Preloader/U-Boot with WSL [Part 1] Environment Setup" 

* At the “SoC Startup Trial Seminar” held in our company, it will be set up beforehand. 

 

____ 1. Start Ubuntu 18.04 LTS running on WSL1. 
Type Ubuntu in the Windows® Start menu and click on the suggested Ubuntu 18.04 LTS app. 

 

 

 

 

 

 

 

 

 

Figure 4-3. Starting the Embedded Command Shell 
  

https://malt.zendesk.com/hc/en-us/articles/900005299906
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 Info: 

In your Linux OS environment, you need to install various packages necessary for building. In the case of Ubuntu 
18.04 LTS, use the following command to add the necessary packages beforehand. "Do you want to continue? [Y/n] 
"appears, enter Y.  

$ sudo apt update  

$ sudo apt upgrade  

$ sudo apt install build-essential bison flex ncurses-dev  

* At the “SoC Startup Trial Seminar” held in our company, it will be set up beforehand. 

 

____ 2. Install the bare metal GCC toolchain on Ubuntu 18.04 LTS on WSL1.  
Run the following command in Ubuntu 18.04 LTS terminal to download and extract the GCC toolchain. If already 
installed, proceed to the next step. 

$ mkdir ~/toolchains  

$ cd ~/toolchains  
$ wget https://releases.linaro.org/components/toolchain/binaries/latest-7/arm-

eabi/gcc-linaro-7.5.0-2019.12-x86_64_arm-eabi.tar.xz  

$ tar xf gcc-linaro-7.5.0-2019.12-x86_64_arm-eabi.tar.xz  

 Info: 

Downloading the GCC toolchain takes time due to the large file size. 

* At the “SoC Startup Trial Seminar” held in our company, it will be set up beforehand. 

 

____ 3. Set environment variables to use the bare metal GCC toolchain. 
Run the following command in the Ubuntu 18.04 LTS terminal: 

$ export PATH=~/toolchains/gcc-linaro-7.5.0-2019.12-x86_64_arm-eabi/bin:$PATH  

$ export ARCH=arm  

$ export CROSS_COMPILE=arm-eabi-  
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 Step 4: Build Preloader 

Generate the bsp project needed to generate Preloader from the Quartus® Prime design handoff information 
(hps_isw_handoff¥soc_system_hps_0). 

____ 1. Change the current directory in the Ubuntu 18.04 LTS terminal to the bsp project directory. 

$ cd /mnt/c/lab/soc_lab/cv_soc_lab/software/spl_bsp  

 

 

 
 

Figure 4-4. Navigate to the bsp project directory 

____ 2. Download and unpack the U-Boot/Preloader source tree under the bsp project directory. Run the following command 
in your Ubuntu 18.04 LTS terminal: 

$ wget https://github.com/altera-opensource/u-boot-

socfpga/archive/ACDS20.1STD_REL_GSRD_PR.tar.gz  

$ tar -xzvf ACDS20.1STD_REL_GSRD_PR.tar.gz  

$ mv u-boot-socfpga-ACDS20.1STD_REL_GSRD_PR/ uboot-socfpga  

 Info: 

If wget is not available, such as when working offline, use the downloaded source tree. Instead, use the following 
command to copy and unpack the U-Boot/Preloader source tree:  

$ tar -xzvf /mnt/c/lab/soc_lab/cv_soc_lab/solution/uboot-

socfpga/ACDS20.1STD_REL_GSRD_PR.tar.gz  

$ mv u-boot-socfpga-ACDS20.1STD_REL_GSRD_PR/ uboot-socfpga  

*For the “SoC Startup Trial Seminar” in our company, follow these steps. 

____ 3. Navigate directly to the Uboot-socfpga source tree and run qts-filter.sh. 

$ cd uboot-socfpga  
$ ./arch/arm/mach-socfpga/qts-filter.sh 

cyclone5 ../../../ ../ ./board/altera/cyclone5-socdk/qts/  

This action populates the various header files generated by bsp-create-settings below the uboot-socfpga source tree. 
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____ 4. Configure the U-Boot/Preloader source tree for the Cyclone V SoC target. 

$ make socfpga_cyclone5_defconfig  

 

 

 

 

 

 

 
Figure 4-5. Configuring the U-Boot/Preloader Source Tree 

____ 5. Rewrite part of the U-Boot/Preloader source tree for debugging. 
Execute the following command in the Ubuntu 18.04 LTS terminal to edit in the vi editor. 
After starting the editor, type the i key to enter the input mode. Rewrite the source according to the figure below. 
After editing, press the ESC key once, then type : wq to save and exit. 

 Info: 

In the vi editor, you can search in the file by entering the / (slash) key followed by a search keyword while in normal 
mode. If you are in input mode (with – insert – or – INSERT – displayed at the bottom left of the window), press the 
ESC key once to enter normal mode. 

If you cannot find the edit point in the source, use /spl_boot_device or /socfpga_sdram_apply_static_cfg to search 
in the file, referring to the information in the bubble below. 

 

$ vi arch/arm/mach-socfpga/spl_gen5.c  

 

 

 

 

 

 

 

 
Figure 4-6. Edit Arch/arm/mach-socfpga/spl_gen5.c 

  

* Header Include Added: 

#include <asm/arch/fpga_manager.h> 

* spl_boot_device Add the following to the beginning: 

if(fpgamgr_test_fpga_ready()) { 
/* bridge enable */ 
do_bridge_reset(1, 7); 

 } 
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$ vi arch/arm/mach-socfpga/misc_gen5.c  

 

 

 

 

 

 

 

 

Figure 4-7. Edit Arch/arm/mach-socfpga/misc_gen5.c 

 Info: 

This source code edit adds processing to open the bridge interface between the HPS-FPGA during Preloader. It adds 
processing equivalent to what is normally done with the bridge enable command when running U-Boot. 

 Reference:  
Macnica Altera FPGA Insights "U-Boot HPS-FPGA Bridge Open Command for SoC FPGAs" 

____ 6. Build the source tree and generate the U-Boot and Preloader. 

$ make -j 24  

 

  

 

 

 

 

 

 

 

Figure 4-8. Generating the U-boot and Preloader 
  

* socfpga_sdram_apply_static_cfg Comment out the previous 

preprocessor definition: 

//#ifndef CONFIG_SPL_BUILD 

* Comment out the last preprocessor definition: 

//#endif 

https://malt.zendesk.com/hc/en-us/articles/900005300186
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____ 7. After executing the command, confirm that it finished without any errors. 

After confirming that it finished without any errors, confirm that u-boot-with-spl.sfp has been generated by the ls  
command. 
This file is a binary file that contains both U-Boot and Preloader, and is written to an SD card or QSPI flash memory. The 
mkpimage header referenced by BootROM is attached to the Preloader portion, and the mkimage header information 
referenced by Preloader is attached to U-Boot. 

Lab 2 is now complete. 
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 Lab 3: Software Exercise (2) Bare Metal Application 

In this section, you will use Arm® DS to run the Hello World sample application included with the SoC EDS and the LED 
Blink sample application provided for this exercise to demonstrate software development and debugging techniques. 

The sample application is outlined below. 

 Hello World Sample Application Overview 

This sample application uses the semi-hosting capabilities of Arm® DS to print a "Hello Tim" message to the 
debugger console. 

This method does not use device peripherals and all communication is done through JTAG. 

The application to run is downloaded to 64KB of on-chip RAM and starts running. This eliminates the need to 
configure SDRAM memory on the board. 

For these reasons, it can run on any board with Altera® SoC FPGAs. 

 Overview of the LED Blink Sample Application 

This sample application uses the FPGA design created in "3. Lab 1: Hardware Exercise" and accesses the PIO 
peripherals on the FPGA fabric side from the Arm® processor to control the LEDs on and off. 

Before running the main application, this sample application runs the HPS block initialization software called 
Preloader to calibrate the SDRAM, set the clock, and initialize the bridge between the HPS-FPGA. This allows 
the main application to run with the peripherals on the FPGA fabric side accessible. The main application also 
loads into SDRAM and starts running. 


  Note:  
 This document uses Arm® DS version 2020.1. Use the appropriate version of Arm® DS for your environment. 

 Before performing this exercise, ensure that Linux® (or another OS) is not running on the board. The OS can 
interfere with the ability to download and debug bare metal applications (If a microSD card is inserted, remove 
it). 

 The descriptions, screen snapshots, and commands in this section were created using the Windows® version 
of SoC EDS, but they can be run in a similar manner on a Linux host PC. 

 The paths in this section assume you have used the default installation path. If a non-standard location is used, 
adjust accordingly. 

 A license is required to debug bare metal applications on an Arm® DS. The license is tied to the MAC Address. 
Make sure the PC knows the network interface associated with the license. 
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 Download the FPGA Design 

Before starting the software exercises, download the hardware design "3. Lab 1: Hardware Exercise" to the FPGA. 
Refer to the section on "2 Board Setup" and verify that the board setup is complete again. If the setup is OK, connect 
the AC adapter to the J14. 

____ 1. In Quartus® Prime, click Tools menu => Programmer or Programmer icon    to start Programmer. 

____ 2. Click the [Hardware Setup] button in Programmer, select the DE-SoC from the currently selected hardware pull-down 
list in the Hardware Setup window, and close the window. 

 

 

 

 

 

 

 

 

 

Figure 5-1. Hardware Setup 

____ 3. Click the [Auto Detect] button to detect the FPGA connected to the JTAG chain on the board. 

____ 4. Select 5CSEMA4 for the Atlas-SoC board or 5CSEBA6 for the DE10 Nano board from the Select Device window, and 
click [OK]. 

 

 

 

 

 

 

 

 

 

 

Figure 5-2. Device selection 
  

5CSEMA4 for the Atlas-SoC board 
5CSEBA6 for the DE10 Nano board 
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____ 5. If the following dialog box appears, select [Yes]. 

 

 

 

 

Figure 5-3. Dialog box 

This displays SOCVHPS and 5CSMA4/5CSEBA6 on the JTAG Chain. SOCVHPS indicates that the HPS side has been 
recognized, and 5CSMA4/5CSEBA6 indicates that the FPGA side has been recognized. 

____ 6. Select the file to download. 

Right-click 5CSEMA4/5CSEBA6 in the Device field and click Change File. In the Select New Programming File dialog box, 
browse to c:¥lab¥soc_lab¥cv_soc_lab¥output_files and select atlas.sof for an Atlas-SoC board or DE10 Nano.sof for a 
DE10 Nano board. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-4. sof file selection 
  

 

Right-click 
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____ 7. Check Program/Configure and click the [Start] button to perform the configuration. 
When the Progress par in the upper right reaches 100%, the operation image is written to the FPGA. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-5. Download sof 
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 Run the Hello World sample application 

Now let's run the sample application on HPS. Start Arm® DS. 

____ 1. Start Arm® DS from the Embedded Command Shell included with the SoC EDS. Start the Embedded Command Shell by 
double-clicking the Embedded_Command_Shell.bat startup script located in the Windows® Start menu or in the SoC 
EDS installation folder. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-6. Starting the Embedded Command Shell 

____ 2. Run the following command in the Embedded Command Shell to start Arm® DS. 

$ exec /cygdrive/c/Program¥ Files/Arm/Development¥ Studio¥ 2020.1/bin/cmdsuite.exe  
> bash  
$ armds_ide &  

 

 

 

 

 

 

 

 

Figure 5-7. Arm® DS Launch and Launch Screen 
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____ 3. Set up a workspace folder for working with Arm® DS. 
In this exercise, you create a workspace in the "3. Lab 1: Hardware Exercise" working folder. 
Specify the following path and click [Launch] (if the folder does not exist, it will be created automatically): 

C:¥lab¥soc_lab¥cv_soc_lab¥workspace 

 

 

 

 

 

 

 

Figure 5-8 Creating a Workspace 

____ 4. If the Preferences Wizard appears, confirm the contents and click [Apply & Close]. If the Arm® DS Welcome screen 
appears, click Close (X) to close it. 

 

 

 

 

 

 

 

 

 

Figure 5-9. Preference Wizard and Welcome Screen 

 Info: 

When displaying the Welcome screen (tutorial and video) online in Arm® DS (2020.1), it has been confirmed that 
window operations become unresponsive. Do not force the operation until the online display is complete. After 
closing the Welcome screen, you will be able to operate smoothly. 
If you start Arm® DS offline, the offline Welcome screen will be used to avoid this problem. 
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Next, import the Hello World sample application. 
The Hello World sample application is included in the SoC EDS as a Software Example. 

____ 5. From the Arm® DS menu, select File => Import. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-10. Import menu 

____ 6. Select "Existing Projects into Workspaces" and click [Next]. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-11. Import an existing project 
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____ 7. Select archive file: option and use the [Browse] button to locate the sample project. 
The sample project is included with SoC EDS and can be found by default in the following installation folder: 

C:¥intelFPGA¥20.1¥embedded¥examples¥software¥Altera-SoCFPGA-HelloWorld-Baremetal-GNU.tar.gz 

(Importing <SoC EDS installation directory >¥examples¥software¥Altera-SoCFPGA-HelloWorld-Baremetal-GNU.tar.gz). 

Once selected, click the [Finish] button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-12. Selecting the Hello World sample application 

After you complete this task, the Project Explorer on the left side of the Arm® DS window displays the various files 
contained in the project. 
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Next, compile the Hello World sample application. 

____ 8. Select and highlight the project from the Project Explorer tab. 

____ 9. From the Arm® DS menu, choose Project => Build Project. Alternatively, select the project in the Project Explorer and 
right-click => Build Project. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-13. Building the Hello World project 

The project is compiled, and the Project Explorer contains a file named hello.axf, as shown in the figure above. The 
executable binary on Arm® DS is output. 

The Console window shows the command executed to generate the executable binary. 
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Finally, run the Hello World sample application (hello.axf) generated earlier. 

____ 10. Choose Run menu => Debug Configuration (B). 

 

 

 

 

 

 

 

 

Figure 5-14. Selecting the Debug Configuration 

____ 11. From the left panel of the Debug Configurations window, select 
Generic ARM C/C++ Applications => Altera-SoCFPGA-HelloWorld-Baremetal-Debug (If you do not see it, click (>) next 
to Generic ARM C/C++ Application). 
The target connection uses the Intel ® FPGA Download Cable (USB-Blaster™). 
Intel SoC FPGA => Cyclone V SoC (Dual Core) => Bare Metal Debug => Debug Cortex-A9_0. 

____ 12. Press the [Browse] button to the right of the connection section to bring up the selection screen for the USB-Blaster™ 
connection. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-15. Debug configuration (connection tab) 
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____ 13. In the connection browser window, highlight the desired USB-Blaster™ (in this example, DE-SoC on localhost) and click 
[Select]. 

 

 

 

 

 

 

Figure 5-16. Select debug cable 

____ 14. Modify semihost_setup.ds specified in the target initialization debugger script (.ds/.py) in the Debugger tab. Select 
semihost_cvav_setup.ds included in the project from the [Workspace] button and click [OK]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 5-17. Debug configuration (Debugger tab) 

____ 15. Click the Debug button in the lower right corner of the [Debug] configuration window. 

 

 

 

Figure 5-18. Running debugging  
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____ 16. If prompted for a perspective switch, click [Yes] to accept it. 

 

 

 

 

 

Figure 5-19. Check the perspective switch 

If you receive a Windows Defender Firewall warning, click [Allow access]. 

 

 

 

 

 

 

 

Figure 5-20. Security warning 

 Info: 

If you receive a download error, check the following: 

(1) Make sure that the network interface (for example, USB-Ethernet Interface Adapter) to which the Arm® DS is 
licensed is enabled. 

(2) Make sure that the evaluation board is powered off and that the PC is rebooted. If the evaluation board is 
powered off, remember to download the FPGA data again. 

The debugger will follow the instructions in the startup script to enable the semi-hosting feature and then download 
the application to the board via JTAG. When the program counter reaches the main function, it breaks and you are 
ready to start debugging. At this point, you can use all the debugging features of Arm® DS (View and edit registers and 
variables, reference disassembly code, etc.). 
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____ 17. The green Continue button  Click (or press F8) to run the application. This will display a Hello Tim message in 
the App Console. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 5-21. Displaying Hello Tim 

____ 18. Disconnect button  to disconnect from the CPU. 

____ 19. If you are changing the perspective in the upper right corner of the screen, click  to return to the 

main screen. 

 Info: 

You can use the perspective menu in the upper right corner of the Arm® DS window to store several different 
screen layouts. You can switch between perspectives depending on what you are doing. 

button to open a new perspective. The perspectives are listed in icon form in the upper right corner and can 
be switched by clicking the icon. You can also reset the selected perspective by right-clicking it. 
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 Running the LED Blink Sample Application 

Import the pre-installed LED Blink sample application, similar to the Hello World sample application, into Arm® DS. 

____ 1. From the Arm® DS menu, select File => Import. 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-22. Import menu 

____ 2. General => "Existing Projects into Workspaces" Select and click [Next]. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-23. Import an existing project 
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____ 3. Select the Select archive file: option and use the [Browse] button to locate the sample project. 

C:¥lab¥soc_lab¥cv_soc_lab¥software_example¥Atlas-Blinking-LED-Baremetal-GNU.tar.gz 

 Info: 

Note that this is under the exercise data directory, not the tool installation directory. 

After making your selections, press the [Finish] button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-24. Selecting the LED Blink sample application 

After completing this task, the Project Explorer on the left side of the Arm® DS window displays the various files 
contained in the project. 
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Next, compile the LED Blink sample application. 

____ 4. From the Project Explorer tab, select and highlight the Atlas-Blinking-LED-Baremetal-GNU project. 

____ 5. From the Arm® DS menu, select Project => Build Project. Alternatively, select the project in the Project Explorer and 
right-click => Build Project. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 5-25. Building the LED Blink Sample Application 
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Finally, run the LED Blink sample application. 

____ 6. Choose Run menu => Debug Configuration (B). The sample project comes with pre-configuration to run on an Atlas-
SoC board. 

____ 7. From the left panel of the Debug Configurations window, select 
Generic ARM C/C++ Application => Atlas-Blinking-LED-Baremetal-Debug (If you do not see it, click (>) next to Generic 
ARM C/C++ Application). 

The target connection is already configured using USB-Blaster™. 
Intel SoC FPGA => Cyclone V SoC (Dual Core) => Bare Metal Debug => Debug Cortex-A9_0. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-26. Debug configuration of the LED Blink sample application 

____ 8. If the following confirmation popup appears, select [Yes]. 

 

 

 

 

Figure 5-27. Confirmation popup 
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____ 9. Press the [Browse] button to the right of the connection section and select the USB-Blaster™ connection. 

____ 10. In the connection browser window, highlight the desired USB-Blaster™ (DE-SoC on localhost in this example) and click 
Select. Click [Select]. 

 

 

 

 

 

 

 

Figure 5-28. Selecting a Debug Cable 

____ 11. Click the [Debug] button in the lower right corner of the Debug Configurations window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-29. Debugging the LED Blink sample application 
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____ 12. If prompted to confirm the perspective switch, click [Yes] to accept it. 

 

 

 

 

 

Figure 5-30. Checking the perspective switch 

If you receive a Windows Defender Firewall warning, click [Allow access]. 

 

 

 

 

 

 

 

 

Figure 5-31. Security warning 

 Info: 

If you receive a download error, check the following: 

(1) Make sure that the network interface (for example, USB-Ethernet Interface Adapter) to which the Arm® DS is 
licensed is enabled. 

(2) Check if turning the evaluation board off and restarting the PC will not recover. If you turn off the evaluation 
board, remember to download the FPGA data again. 

 
  



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ve r. 2 0 . 1 / Re v. 4  A p r i l  2 0 2 5                   7 8 / 1 1 1                     A LT I M A  C o m p a ny,  M a c n i ca ,  I n c .                    

 

 

____ 13. Set a breakpoint. 
Set a breakpoint on line 26 of atlas_main.c. You can set it by double-clicking the space to the left of the line number 
display. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-32. Setting breakpoints 

____ 14. green Continue button  to run the application (or press F8). This displays a Hello from Atlas message in the App 
Console. A message is displayed. 

____ 15. Click the green Continue button   twice again (or press F8) to run the application. This displays an LED [0] 
message in the application console and you can see that the user LED (LED [3: 0]) on the Atlas-SoC board changes 
state.  

____ 16. Furthermore, confirm that the LED state changes each time you click the Continue button. 
____ 17. Disconnect button  to disconnect from the CPU. 

This completes Lab 3. Thank you! 

There are optional exercises from the next page. If you have time, try them too. 
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 Initialize with Preloader created in Lab 2 (optional exercise) 

In Lab 3, you initialized HPS using the preloaded Preloader. 
Now you will initialize HPS with the Preloader created in "4. Lab 2 - Software Exercise (1) Generate Preloader". 

____ 1. Verify that the Preloader image was created in Lab 2. 
The Preloader should be created under the  
C:¥lab¥soc_lab¥cv_soc_lab¥software¥spl_bsp¥uboot-socfpga¥spl  
directory and named u-boot-spl. Verify that this file has been generated. Also, make sure that a device tree “u-boot-
spl.dtb” has been created in the same directory as the Preloader itself. 

If not, repeat Lab 2. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-33. Checking the U-boot-spl File 

 Info: 

The u-boot-spl file you just checked is an Arm® Executable and Linkable Format (ELF) file. 
It is read by the Arm® DS initialization script and executed before running the user application. 

For details, please refer to the chapter "How to support custom boards" in the reference article below.  
(The reference article is for DS-5™, but the concept is similar for Arm® DS.) 


  Reference: Getting Started with SoC – Bare Metal Application Debugging with DS-5 (in Japanese) 
  

https://www.macnica.co.jp/business/semiconductor/articles/intel/118693/
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____ 2. Rename the “u-boot-spl.axf” file used in Lab 3. 

C:¥lab¥soc_lab¥cv_soc_lab¥workspace¥Atlas-Blinking-LED-Baremetal-GNU contains the file “u-boot-spl.axf”. 

____ 3. Copy the files “u-boot-spl.dtb” and "u-boot-spl" created in Lab 2. 

Copy the files “u-boot-spl.dtb” and "u-boot-spl" under the directory  
C:¥lab¥soc_lab¥cv_soc_lab¥software¥spl_bsp¥uboot-socfpga¥spl  

to the directory  
C:¥lab¥soc_lab¥cv_soc_lab¥workspace¥Atlas-Blinking-LED-Baremetal-GNU. 

____ 4. Rename the copied “u-boot-spl.axf” file. 

You have now modified the Preloader you will use when debugging. 
Let's see if it works. 

____ 5. Run the LED Blink sample application again. 

Run it from “____ 6 Choose Run menu => Debug Configuration (B). The sample project comes with pre-configuration 
to run on an Atlas-SoC board..” on page 75. 

 

If the LED Blink sample application runs as before, the Preloader created in Lab 2 is working correctly. 
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 Address resolution using system header files (optional exercise) 

The LED Blink sample application in Lab 3 addressed the LED PIO directly in the source code. 

 

 

 

 

 

 

 

 

 

Figure 5-34. How to address so far 

Let's use the SoC EDS system header file generation command (sopc-create-header-files) to generate and use the 
system header file. 

____ 1. Start the Embedded Command Shell if it is not already running. 

____ 2. Navigate to C:¥lab¥soc_lab¥cv_soc_lab. 

$ cd “C:¥lab¥soc_lab¥cv_soc_lab”  

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-35. Moving directories 
  



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ve r. 2 0 . 1 / Re v. 4  A p r i l  2 0 2 5                   8 2 / 1 1 1                     A LT I M A  C o m p a ny,  M a c n i ca ,  I n c .                    

 

 

____ 3. In the Embedded Command Shell, run the system header file generation command (sopc-create-header-files). 

$ sopc-create-header-files soc_system.sopcinfo  

 

 

 

 

 

Figure 5-36. Executing system header file generation command (error) 


  Note: 

If your operating system is Windows® 10, the error shown above may occur. If the error occurs, take the corrective 
action described in the following reference site, and then re-execute sopc-create-header-files. 


  Reference:  
Macnica Altera FPGA Insights "Workaround for sopc-create-header-files execution error in SoC EDS environment" 

 

 

 

 

 

 

 

Figure 5-37. Executing the system header file generation command (success) 

Verify that 5 files have been generated. 

soc_system.h     :  Define module information for all masters in Platform Designer 

hps_0.h         :  Define module information connected to each bridge (H2F, LWH2F) in HPS 

hps_0_bridges.h  :  Define module information connected to each bridge (F2H, H2F, LWH2F) in HPS 

hps_0_arm_a9_0.h :  Define module information for hps_0_arm_a9_0. Offsets for each bridge are added. 

hps_0_arm_a9_1.h :  Define module information for hps_0_arm_a9_1. Offsets for each bridge are added. 

We will use hps_0_arm_a9_0.h. 
  

https://malt.zendesk.com/hc/en-us/articles/900005301606
https://malt.zendesk.com/hc/en-us/articles/900005301606
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____ 4. Copy the system header file to the LED Blink sample application project. 

File name : hps_0_arm_a9_0.h 
From : C:¥lab¥soc_lab¥cv_soc_lab 
To : C:¥lab¥soc_lab¥cv_soc_lab¥workspace¥Atlas-Blinking-LED-Baremetal-GNU 

____ 5. Modify the LED Blink sample application source code atlas_main.c. 

Select Yes if you see a "Do you want to make it writable?" pop-up when you make the change. 

Description added: 

#include “hps_0_arm_a9_0.h” 

Description changed: 

< before change > #define LED_BASE_ADDR (0xFF210040) 
< after change >  #define LED_BASE_ADDR LED_PIO_BASE 

In the following figure, the previous LED_BASE_ADDR description has been commented out for ease of comparison. 
For reference, the corresponding parts of "hps _0_arm_a9_0 .h" are also shown. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5-38. Source code changes and system header files 

____ 6. Save the modified atlas_main.c and build the LED Blink sample application. 

____ 7. After the build, run the LED Blink sample application and verify that the results are similar to those in Lab 3. 

This completes Lab 3 (optional). 
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 Lab 4: Linux Application Exercise (optional exercise) 

In this exercise you will run and debug Hello World, one of the Linux applications, from Arm® DS. 

 Info: 

For this exercise, if you have a SoC FPGA Seminar ina Box provided by our company, you will use the included 
microSD card. 
This microSD card contains a design to boot the Linux OS. 
If you are not using a SoC FPGA Seminar ina Box to perform this exercise, please prepare your own microSD card 
by following the instructions in "6-1. Preparing the microSD card" below. 
 

 Preparing the microSD card 

If you are using the microSD card supplied with the “SoC FPGA Seminar in a Box”, skip this section and use the "6-2. 
Linux Boot and Login" below. If you want to burn the microSD card yourself, follow the steps below. 

____ 1. Download the SD card image file for your board from the following site. 
Extract the downloaded file to a folder of your choice. Make sure that the .img image file exists in the extracted folder. 

 Atlas-SoC board SD card image file 

 DE10 Nano board SD card image file 

____ 2. Windows® users use general-purpose software to write SD card image files. This section introduces Win32 Disk Imager. 
You can download it from: 

 Win32 Disk Imager 

____ 3. Insert the microSD card (8GB or more recommended) into the SD card slot of the PC (or use a USB card reader/writer). 
Check the drive (In this example, drive E) assigned to the microSD card. 

 

 

 

 

 

Figure 6-1. Check the drive assigned to the microSD card 
  

https://rocketboards.org/foswiki/pub/Documentation/JapanesePortal/atlas_exte_sdimage_4.14.73-ltsi_a.tgz
http://www.terasic.com/downloads/cd-rom/de10-nano/linux_BSP/DE10_Nano_Xfce.zip
http://sourceforge.net/projects/win32diskimager/files/latest/download
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____ 4. Launch the Win32 Disk Imager that you previously installed on your PC. 

① Make sure the drive of the microSD card that you inserted into your PC is selected as the Device. 

② Select and open the SD card image file that you extracted earlier. 

③ Click the [Write] button to write the image file. 

④ Click the [OK] button when writing is complete. 

⑤ Click the [Exit] button to exit Win32DiskImager. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 6-2. Win32 Disk Imager 

____ 5. Safely remove the microSD card from the PC. 


  Note: 

If the host PC is running Windows® 10 and you are writing an SD card and there is a non-FAT partition (volume) in the 
card, the following symptoms may occur: 

 Warning window appears when inserting the card 

 SD card image fails to write 

For information on how to handle these symptoms, see the following reference sites: 


  Reference:  
Macnica Altera FPGA Insights "What to do if writing an SD card image fails in Windows® 10" 

  

②

①

③ ⑤

④

https://malt.zendesk.com/hc/en-us/articles/900006257643
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 Linux Boot and Login 

This exercise uses the following interfaces. 
The following is an example of an Atlas-SoC board, but the DE10 Nano board is essentially the same. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-3. Interface used in this exercise (Atlas-SoC board) 

____ 1. If the power adapter is connected to the 5 V DC jack (J14) on the board, unplug it. 

____ 2. Connect the USB Mini-B cable to the UART USB connector (J4) on the board. Connect the other end of the cable to the 
USB connector on the PC. 

____ 3. Connect the Ethernet cable to the HPS Ethernet connector (J10) on the board. Connect the other end of the cable to 
the Ethernet connector on the PC. 

____ 4. Insert the microSD card into the microSD card slot (J11) on the back of the board. 

____ 5. Connect the power adapter cable to the 5 V DC jack (J14) on the board and power on the board. 
  

(J14) 

(J4) 

(J10) 

(J11) 
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____ 6. Open Windows® Device Manager. Expand Ports (COM & LPT) in Device Manager and check the COM port number of 
the UART on the board (COM 4 in this example).  
Close Device Manager. 

 

 

 
Figure 6-4. Checking the COM Port 

____ 7. Start the terminal software that you have previously installed, and set the serial port. Select the COM port that you just 
checked, and set it as shown below (COM 4 in this example). 

 

 

 

 

 

 

 

 
Figure 6-5. Serial Port Settings 

____ 8. Press the WARM reset button (KEY3) on the board. The terminal displays a boot message. 

 

 

 
Figure 6-6. WARM reset button (KEY3) 

____ 9. After the Linux kernel boots, log in as root  
 
 
 
 
 
 
 
 
 

Figure 6-7. Login as Root  
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 Setting the IP Address and Password on Linux 

____ 1. From a terminal, use the ifconfig command to set the IP address of the board (192.168.1.30 in this example). 

# ifconfig eth0 192.168.1.30  

____ 2. Then use the ifconfig command to verify the settings. 

# ifconfig eth0  

____ 3. Use the Passwd command to set the password of your choice. This password will be used later for remote system 
debugging. 

# passwd  

____ 4. Enter the password again. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-8. Setting the IP Address and Password 
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 Network Settings on the Host PC 

To run and debug Linux applications using Remote System Explorer (RSE) on the Arm® DS, set the network settings on 
the host PC. 

____ 1. First, set the IP address of the host PC. From the Control Panel, click Network and Sharing Center, then click Change 
Adapter Settings on the left. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-9. Changing Adapter Settings 

____ 2. Double-click Ethernet. 
 
 
 

Figure 6-10. Double-click Ethernet 

____ 3. Click the [Properties] button. 

____ 4. Double-click Internet Protocol Version 4 (TCP/Ipv4). 
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Figure 6-11. Local Area Connection Properties 

____ 5. Select the "Use the following IP address:" checkbox and specify the "IP address" and "Subnet mask" (This example 
sets the IP address to 192.168.1.31 and the subnet mask to 255.255.255.0.). 
Click [OK] when finished. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-12. Setting the "IP address" and "Subnet mask" 
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____ 6. Check network connectivity. Try pinging the host PC from Linux on the board (In this example, the IP address of the PC 
is set to 192.168.1.31.). 

# ping 192.168.1.31  

____ 7. Ctrl  +  C   to stop the ping. 
 
 
 
 
 
 
 

Figure 6-13. Ping the PC to check connectivity 

____ 8. If there is no ping response, check the Windows Defender Firewall settings. 
Check the Public Network Settings and if Windows Defender Firewall is set to "Enabled," set it to "Disabled" and ping 
again to check connectivity. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 6-14. Windows Firewall settings 
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 Start Arm® DS and import and build the Linux sample application 

____ 1. Start the Embedded Command Shell by double-clicking the startup script Embedded_Command_Shell.bat from the 
Windows® Start menu or the SoC EDS installation folder (intelFPGA ¥embedded). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-15. Launch Embedded Command Shell 

____ 2. Run the following command on the Embedded Command Shell to launch Arm® DS: 

$ exec /cygdrive/c/Program¥ Files/Arm/Development¥ Studio¥ 2020.1/bin/cmdsuite.exe  
> bash  
$ armds_ide &  

 

 

 

 

 

 

 

 

Figure 6-16. Launch Arm® DS from the Embedded Command Shell 
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____ 3. Set up a workspace folder for working with Arm® DS. 
In this exercise, you will create a workspace in the working folder of "3. Lab 1: Hardware Exercise". 
Specify the following path and click [Launch] (if the folder does not exist, it will be created automatically): 

C:¥lab¥soc_lab¥cv_soc_lab¥workspace 

 

 

 

 

 

 

 

 
Figure 6-17. Creating a Workspace 

____ 4. If the Preferences Wizard appears, confirm it and click [Apply & Close]. If the Arm® DS Welcome screen appears, click 
Close (X) to close it. 

 

 

 

 

 

 

 

 

 

Figure 6-18. Preference Wizard and Welcome Screen 

 Info: 

In Arm® DS (version 2020.1), it has been confirmed that window operation becomes slow when the Welcome screen 
(tutorial and video) is displayed online. Please wait until the online display is complete without forcing the operation. 
After closing the Welcome screen, operation will be smooth. 
If you start Arm® DS offline, the offline Welcome screen is used, and this problem can be avoided. 
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____ 5. From the Arm® DS menu, select File => Import. 

____ 6. Select General => "Existing Projects into Workspaces" and click [Next]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-19. File => Import 
  



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ve r. 2 0 . 1 / Re v. 4  A p r i l  2 0 2 5                   9 5 / 1 1 1                     A LT I M A  C o m p a ny,  M a c n i ca ,  I n c .                    

 

 

____ 7. Select archive file: option and use the [Browse] button to locate the sample project. 
The sample project is included with SoC EDS and can be found by default in the following installation folder: 
C:¥intelFPGA¥20.1¥embedded¥examples¥software¥Altera-SoCFPGA-HelloWorld-Linux-GNU.tar.gz 

(Importing <SoC EDS installation directory >¥examples¥software¥Altera-SoCFPGA-HelloWorld-Linux-GNU.tar.gz).  

Once selected, click the [Finish] button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-20. Importing the sample project 
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____ 8. The Altera-SoCFPGA-HelloWorld-Linux-GNU project has been added to the Project Explorer on the left side of the Arm® 
DS window. Click and expand Altera-SoCFPGA-HelloWorld-Linux-GNU to view the various files contained in the project. 
If the project icon is marked with a red X    , the tool chain is configured. If the X is not marked, ____ 11 Go to. 

 

 

 

 

Figure 6-21. Altera-SoCFPGA-HelloWorld-Linux-GNU project added (toolchain not found) 

____ 9. In the Project Explorer, select Properties from the right-click menu for Altera-SoCFPGA-HelloWorld-Linux-GNU to view 
the project properties. In C/C++ Build => Tool Chain Editor, Current toolchain: is unselected, so select arm-one-linux-
gnueabihf or arm-linux-gnueabihf and click [Apply and Close]. If you have selected a toolchain, go to ____ 11 Go to. 
If arm-one-linux-gnueabihf or arm-linux-gnueabihf is not a candidate, follow 0 and then repeat this procedure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-22. Selecting the Linux GCC toolchain 
  

Right-click 
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____ 10. Select "Window" menu => "Preferences," then "ARM DS" => "Toolchains." Since GCC (arm-linux-gnueabihf or arm-
none-linux-gnueabihf) for Linux is not in the list, use the [Add] button and follow the instructions in the window to add 
the toolchain. When the addition is complete, restart Arm® DS. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-23. Adding the Linux GCC toolchain 

____ 11. The Altera-SoCFPGA-HelloWorld-Linux-GNU project has been added to the Project Explorer. Click on Altera-SoCFPGA-
HelloWorld-Linux-GNU to expand it and view the various files contained in the project. 

 

 

 

 

 

Figure 6-24. Altera-SoCFPGA-HelloWorld-Linux-GNU project added (normal) 
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____ 12. Build the Altera-SoCFPGA-HelloWorld-Linux-GNU application. 

Highlight the Altera-SoCFPGA-HelloWorld-Linux-GNU project in the Project Explorer and choose 
Project => Build Project. Alternatively, select the project in the Project Explorer and right-click Build Project. 

The newly generated hello executable is output in the Project Explorer. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-25. Building the project 
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 Setting up Remote System Explorer (RSE) 

With Arm® DS, you can use Remote System Explorer (RSE) to run and debug Linux application programs on the target. 

____ 1. Choose Window => Perspective => Open Perspective => Other. 

 

 

 

 

 

 

 

 

Figure 6-26. Choose Open Perspective -> Other 

____ 2. Select "Remote System Explorer" and click [Open]. 

 

 

 

 

 

 

 

 

 

Figure 6-27. Selecting Remote System Explorer 

____ 3. In the Remote System Explorer view     button or right-click a blank area and select New Connection. 
 
 
 
 
 

Figure 6-28. New connection in Remote System Explorer 
  

or Right-click a blank area 



My First Altera® SoC FPGA Exercise Manual (Atlas-SoC / DE10-Nano Board Edition) 

Ver.2 0. 1/ Rev. 4  Ap r i l  20 25                  10 0/1 1 1                    A LT IM A  Co m pa ny,  Mac n ica ,  I n c .                    

 

 

____ 4. Select SSH Only in the Select Remote System Type view and click [Next]. 

 

 

 

 

 

 

 

 

Figure 6-29. Select SSH Only 

____ 5. In the Host name: field, enter the IP address of the board (192.168.1.30 in this example). In the Connection name: and 
Description: field, enter Atlas SoC or DE10 Nano. Check Verify host name and click [Finish]. 

 

 

 

 

 

 

 

 

 

 

Figure 6-30. Connection Settings 
  

Host name:    192.168.1.30 

Connection name:   Atlas SoC or DE10 Nano 

Description/Description:  Atlas SoC or DE10 
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____ 6. In the Remote System Explorer view, click Atlas SoC (or DE10 Nano) => Sftp Files => Root. A window for entering the 
user ID and password will appear. 

____ 7. Enter "root" for "User ID:" and the password you set for "Password" and click [OK]. 

 

 

 

 

 

 

 

 

Figure 6-31. Enter the User ID and Password 

____ 8. If the warning shown below appears, click [Yes]. 

 

 

 

 

Figure 6-32. Warning display 

____ 9. If the connection is successful, Remote System Explorer displays the files on the current board. 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 6-33. Remote System Explorer displays the files on the current board 
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____ 10. If you are unable to connect with an error, it may be a problem with the proxy settings on the host PC. In this case, click 
"Control Panel" -> "Internet Options," then click "LAN Settings" in the "Connections" tab. 

____ 11. If "Use proxy server for LAN" is checked, uncheck it and click [OK]. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-34. Proxy Server Settings 

____ 12. Try connecting to the root of the Atlas SoC (or DE10 Nano) again. 
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 Running and Debugging Linux Applications 

This section describes how to set up the debugger and how to run and debug it. 
____ 1. Click the  button in the menu bar (top right of the window) to return to the main perspective of Development 

Studio. From the Project Explorer tab, right-click Altera-SoCFPGA-HelloWorld-Linux-GNU. 

____ 2. . From the Project Explorer tab, right-click Altera-SoCFPGA-HelloWorld-Linux-GNU 
Select Debug As => Debug Configurations. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-35. Select “Debug” => “Debug Configuration” 

____ 3. Right-click “Generic ARM C/C++ Application” and select “New Configuration” to create a new debug configuration. 

 

 

 

 

 

 

 

 

 

Figure 6-36. Creating a new debug configuration 
  

Right-click 
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____ 4. Type "HelloWorld" in the Name field. 

____ 5. In the Select Target field of the Connections tab, select 
Intel SoC FPGA => Cyclone V SoC (Dual Core) => Linux Application Debug => Download and debug application. 

____ 6. In the Connection field, select the generated RSE connection (Atlas SoC in this example) and accept the other defaults. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-37. Set debug configuration (1) 
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____ 7. In the File tab, set the Application on host to download to the Hello World executable. Select hello using the 
[Workspace] button and click [OK]. 

 

 

 

 

 

 

 

 

 

 
Figure 6-38. Setting the debug configuration (2) 

____ 8. Set Target Download Directory: and Target Working Directory: to/home/root. 

 

 

 

 

 

 

 

 

 

 
Figure 6-39. Setting the debug configuration (3) 

____ 9. In the Debugger tab, select Debug from symbols as the execution control field and enter main as the symbol name. 
 
 
 
 
 

Figure 6-40. Setting the debug configuration (4) 
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____ 10. Click the [Debug] button  to start the debugging session. 

____ 11. When a debugging session starts, the App Console displays a log similar to the following: 

 

 

 

 

 

 

Figure 6-41. App Console at the start of a debugging session 

____ 12. The application is loaded and then breaks in the main function. 

 

 

 

 

 

 

Figure 6-42. Break in Main function 

____ 13. Double-click the left margin of the source code and the debugger will set a breakpoint there, as indicated by the red 
dot  . 

 

 

 

Figure 6-43. Setting breakpoints 

____ 14. Continue button    (or F8) to run the application and stop at the breakpoint. 
 
 
 
 

Figure 6-44. Stop at breakpoint 
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____ 15. Double-click the breakpoint indicated by a red dot   in the left margin of the source code. To cancel the breakpoint 
setting, double-click the breakpoint indicated by a red dot. 

____ 16. Step Source Line button     (or F5) advances the execution code one line. 

____ 17. You can add various views useful for debugging by selecting "Window" menu => "Show View" => "Other". Select the 
view you want to display from the items listed under "ARM Debugger" and click [Open]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-45. Adding a view 
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____ 18. The Registers view displays the contents of the target register. You can also change the value of a writable register. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 6-46. Registers view 

____ 19. The Variables view displays the contents of a variable that is currently in its valid range. You can also change the value 
of a variable that is currently in its valid range. 

 

 

 

 
Figure 6-47. Variables view 

____ 20. The App Console (application console) view enables you to use the console I/O functionality provided by the semi-
hosting implementation in the Arm C library. The contents of the print statement in the application are displayed. 

____ 21. Continue button     Press the button to continue the application and display Hello SoC FPGA! is displayed. 

 

 

 

Figure 6-48. App Console view 
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____ 22. Clicking  Debug from main() will break the program back to the beginning of the application, main. 

 

 

 

Figure 6-49. Debug Control Debug from main() 

____ 23. Press the Continue     button again. Press the Continue button again to run the application from the top, and the 
App Console view Hello SoC FPGA! is displayed. 

____ 24. Disconnect from Target     button click to end the debugging session. 

____ 25. Delete All Connections button     to delete the debugging session. 

 

 

 

 

 

Figure 6-50. Debug Control Delete All Connections 

____ 26. Right-click the  button at the top right of the window and select Reset to restore the initial screen layout. 

Congratulations! All exercises have now been completed. 
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 Future reference materials 

This exercise focused on learning the basic operations of the Quartus® Prime development software, which is an 
Altera® SoC FPGA development environment, the Platform Designer system integration tool, and the SoC EDS software 
development environment. If you want to improve your knowledge in the future, you can use various information 
sources. 

Please refer to the "SoC Beginner's Guide" for the same information. 


  Reference: 

 SoC Beginner's Guide 

Altera® SoC FPGA Summary Page (in Japanese) 

Beginner's Guide to SoC - Accessing HPS-FPGA (in Japanese) 

Beginner's Guide to SoC - How to use Preloader Generator 

Beginner's Guide to SoC – Bare Metal Application Debugging with DS-5 (in Japanese) 

 SoC Information 

Macnica Altera FPGA Insights 

Macnica Altera FPGA Insights Technical Content Page 

Macnica Altera FPGA Insights FAQ Page 

Macnica Semiconductor Business: SoC FPGA-related articles and resources (in Japanese) 

Macnica Semiconductor Business: SoC FPGA-related FAQs (in Japanese) 

Macnica Semiconductor Business: Altera® FPGA-related FAQs (in Japanese) 

 Description of devices and tools 

Altera® FPGAs and Programmable Devices - FPGA Documentation 

 Various documents and projects that are useful for using Linux on SoC devices 

RocketBoards.org 

Altera Opensource 

 

https://malt.zendesk.com/hc/ja/articles/4414948351257
https://www.macnica.co.jp/business/semiconductor/articles/intel/124437/
https://malt.zendesk.com/hc/en-us/articles/36587354707737
https://www.macnica.co.jp/business/semiconductor/articles/intel/118693/
https://malt.zendesk.com/hc/en-us/articles/36587354707737
https://malt.zendesk.com/hc/en-us/categories/900001338083-Contents-Category
https://malt.zendesk.com/hc/en-us/sections/900000842006-FAQ
https://www.macnica.co.jp/business/semiconductor/articles/query/?kw=SoC%20FPGA&a_cat%5B%5D=basic&a_cat%5B%5D=design&mfr%5B%5D=intel&mfr%5B%5D=intel
https://www.macnica.co.jp/business/semiconductor/support/faqs/query/?kw=SoC_FPGA
https://www.macnica.co.jp/business/semiconductor/support/faqs/query/?kw=intel
https://www.intel.co.jp/content/www/jp/ja/support/programmable/support-resources/fpga-documentation-index.html
https://www.rocketboards.org/foswiki/Main/WebHome
https://github.com/altera-opensource
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